軟工要用到 Astah,幸虧此軟體有提供 Linux 版本。

在下是使用 Antergos,Archlinux 的派生版,直接在 AUR 就可以載得到。

yaourt -S astah-professional

運行 astah

然後發生了 A exception has occurred when launching astah*

原因是 java 版本可能不適用

> superbia commented on 2017-11-01 11:19

> Installed the latest version and it crashes.
> An exception has occured when launching astah*.

> EDIT: Removing the old jdk, and installing the latest one manually fixed the issue.

 

查了一下,其實設定 java 還蠻簡單的。

當初下載的時候,提供了很多不同的版本,而載了之後,他其實有提供一個簡單的工具進行切換。

archlinux-java

使用 archlinux-java status 赫然發現目前只有 jre only,然後之前載的 open jdk 並未被選起來。

(如果你 stats 只有一項,那就去下在最新的 java 再使用此工具做切換)

sudo archlinux-java set java-9-openjdk

# 我的是 java-9-openjdk,也可以試試其他版本,不過 default java-9-jre/jre 不能用

切換之後就可以使用 Astah 了。

eof

 

 

創作者介紹
創作者 nobodyzxc 的頭像
nobodyzxc

Nobody's Zero

nobodyzxc 發表在 痞客邦 留言(0) 人氣()